MathU Pro™ 4.2

User's Guide

IMPORTANT: If you do not see any images and are running Windows XP you need to extract the files from the .zip archive before viewing. Open the .zip file and select "Extract All Files".


What is in this Manual?

This manual contains information on how to use MathU Pro. It describes how to access the features of MathU Pro including the program editor. For information on the functions included with MathU Pro, see the Programming and Function Reference. See the MathU Pro Solver Guide for information on how to use the Solver.


Contents

MathU Pro

Best Pocket Calculator
three years in a row!

MathU Pro has been selected for the ITM praktiker Bestenliste a listing of best hardware and software products for Palm OS and Windows Mobile
2005, 2006 and 2007.

What is MathU Pro?

[Back to Top]

Thank you for evaluating MathU Pro. MathU Pro is a state of the art programmable Reverse Polish Notation (RPN) scientific and financial calculator for Palm OS based handheld computers. It is made for professionals like you. With MathU Pro, you can harness the numerical power of the Palm OS handheld computer to solve your computational problems.

MathU Pro has over a hundred built-in functions and more can be added via programs. It is so easy to program, you can fully customize the keyboard to fit the way you work. All calculations are done in double precision (about 16 digits of accuracy). Programs are easy to write using the included editor and debugger. You can share your programs with friends and colleagues.

Personalize your copy of MathU Pro. Choose from nine different keyboard color schemes (two for B&W devices).

Technical specifications

Comes bundled a units conversion set and calendar function set.

What's new in Version 4.2?

[Back to Top]

MathU Pro 4.2.5 adds:

MathU Pro 4.2.4 added:

MathU Pro 4.2.3 added:

MathU Pro 4.2 added:

MathU Pro 4.1 added:

MathU Pro 4.0 added:

Programs from previous versions of MathU Pro are supported. Programs will be converted to version 4.0 programs after editing. Version 4.0 programs will work with MathU Pro 4.0 or higher but not earlier versions.

Thanks to everyone who submitted suggestions! Please keep them coming! Send any suggestions/comments you have to .

Compatibility

[Back to Top]

There are no compatibility problems with running MathU Pro 2.3 or higher programs with MathU Pro 4.2

System Requirements

[Back to Top]

MathU Pro requires Palm OS 3.5 or higher and 324K of RAM. MathU Pro works on any handheld device that is running PalmOS 3.5 or higher including the Zire, Treo, Tungsten, and Lifedrive series from Palm, Inc, the Handspring Visors, the Sony CLIE, and the Garmin iQue. MathU Pro has been enhanced to take advantage of high resolution and portrait and landscape screens.

In addition, MathU Pro will work on devices running Palm OS 3.0 or higher but the solver and equation editor do not.

Registration

[Back to Top]

MathU Pro features a free 15 day trial. All the features of MathU Pro are available during the trial. The only difference between the trial and a registered version is that the registration screen no longer displays on startup. After the 15 day trial, the five key (5) becomes disabled. If you decide that you like MathU Pro, purchase a registration code to unlock it.

A registration code can be obtained by purchasing MathU Pro from Creative Creek, LLC. You must provide the user name shown in the registration screen to obtain a valid code. The code will be e-mailed to you a few days after registration.

To register your software, select the Display->Registration menu item to bring up the registration screen.

Use graffiti (or the popup keyboard) to enter the registration code you received in the mail into the field following "Reg. code:" and tap OK. If the code you typed in is accepted, a confirmation dialog will appear and the MathU Pro keyboard will be displayed. If you make a mistake in entering in the code, a dialog will indicate that the code wasn't valid and you will be given a chance to edit the code.

If for any reason you have trouble registering your software please contact via the Contact page for assistance.

Installation

[Back to Top]

To install MathU simply unzip the archive you downloaded and use the install tool (or equivalent) to install all the .prc and .pdb files on your Palm device. On most systems, you can just double click the files to move them to the install tool.

You might also consider assigning the calculator button to bring up MathU Pro instead of the default calculator after syncing. To do this, go to the Prefs application, select Personal, and then Buttons. Select MathU Pro from the list next to the button you wish to reassign.

Tungsten T3 only: I f you have a Tungsten T3, download and install MathUProSetupT3.prc which also installs some T3 DIA Compatibility PRC's from Palm, Inc.. These will enable the portrait and landscape screen support on the Tungsten T3.

To uninstall MathU Pro, simply delete MathU Pro via the Palm applications screen.

Previous users: Mathu Pro 4.2 no longer requires MathLib or MathUEdit.

Bundled programs

[Back to Top]

MathU Pro comes bundled with two programs: A unit conversion program (Units) and a calendar program. Use the Palm Desktop install tool (or equivalent) to install both mthUUnits.pdb and either Calendar.pdb (for DD/MM/YYYY style dates) or Calendar_US.pdb (for MM/DD/YYYY style dates) on your Palm device.

Units

[Back to Top]

The units conversion program supports eleven pairs of conversions:

Calendar

[Back to Top]

The calendar program was written by John R Beasley. It provides calendar functions for MathU Pro similar to those available on other calculators. Here are his notes about the program:


Functions are provided that, given two of the following three factors, will calculate the third: one date, a second date, period between the dates. The same keys are used to enter a factor as to calculate that factor. This is achieved by using the input flag to detect whether or not a number has been entered.

Dates are entered as dd.mmyyyy in CALENDAR or as mm.ddyyyy for CALENDAR US.

The period between dates can be given either as a number of days or as a number of weeks & days as w.d. It is possible to convert to/from days from/to weeks & days as well.

Given a date, the day of the week can be calculated. 0 indicates Sunday, 1 Monday, etc.

Invalid dates of certain types are "corrected". For example, if 32 January 2000 is entered it will be converted to 1 February 2000. Dates should lie between 1 March 1900 and 28 February 2100. Beware that no error will be indicated if dates outside this are used.

The primary and secondary registers not used in the implementation. Registers A, B, C, D, M, T, U and Y are used.

Usage and examples

It is advisable to set the calculator display to 6 digit, fixed mode. These examples assume a dd.mmyyyy format for the dates.

Disclaimer

This program is provided without charge, warranty or liability. When using it the user assumes all responsibility for any damages caused, directly or indirectly, by its use.


User contributed function sets

More function sets like John R Beasley 's Calendar are available for download from the User Contributed Programs page on the Creative Creek web site. If you have any function set you've developed that you would like to share with other MathU Pro users, simply follow the submission steps mentioned on the web site.

Basic Operations

[Back to Top]

MathU Pro is based on Reverse Polish Notation (RPN). RPN differs from standard mathematical notation in that the numbers to be operated on are pushed onto a stack and then executed upon by a function. Hence the operation

12.5 + 7

is keyed as

The enter key is used to separate the two values. Most buttons on MathU Pro can access three functions. The function or number on the top of each button is accessed without shifts. The function just above the button is accessed by pressing the f-shift key before pressing the button. The f-shift indicator will light in the display when the f-shift is active. Similarly to access the functions on the front of the buttons use the g-shift key . The g-shift indicator will light in the display when the g-shift is active.

Most functions remember the last x register value used during a computation. This value can be accessed via the button.

MathU Pro has a 16 element stack. The first four elements of this stack are referred to by the names x,y,z, and t.

The value of the x register is what is displayed.

MathU Pro Walkthrough

(A guide to the MathU Pro interface)

Menus

[Back to Top]

Main keyboard menus

(main screen)

(main screen)

(main screen)

Editor menus

(editor screen)

(editor screen)

List screen menu

(list screen)

Debugger screen menu

(debugger screen)

Solver menu

(solver screen)

Preferences

[Back to Top]

The preference screen is displayed when you choose Display->Preferences from the menu or when you tap the degree indicator on the screen (see walkthrough above).

Press OK to commit your changes. Press Cancel to leave them as they were. The More button brings up an additional preference screen.

Pressing Close on this dialog will not affect your current preferences until you press OK on the previous dialog.

Basic Functions

[Back to Top]

Numerals
Change sign of mantissa or exponent.
Start entering exponent
Undo last character (or clear x register)
Minus.
Plus
Times
Divide
Separate values and prepare x register to be overwritten

Support for Non-square Screens

If your device has a non-square screen, you can use MathU Pro in portrait or landscape mode. Some devices only support one of these new layouts, some devices will support both.


Portrait layout

Landscape layout
Simply close the input area to access these layouts.

Keyboard and Treo Support

[Back to Top]

MathU Pro allows you to input numbers using Graffiti or by pressing keys on the Treo keyboard or an external keyboard. The characters 0 through 9, decimal, 'c', 'e' and the graffiti return character can be used instead of the numeric buttons, , , , and . The characters '+', '-', '*', '/' can be used instead of , , and . In hexadecimal mode, you must use Graffiti or the keyboard to enter the letters A through F.

On the Treo, the keyboard is automatically option-locked into numeric mode. Letters like 'e' that share space with the numbers can be accessed by pressing option before pressing the key. After each press, the keyboard will automatically return to numeric mode. Pressing the center of the 5-way is the same as .

When in hex mode, the keyboard is automatically locked into alpha mode in order to make entering A-F easier. To enter numbers, press option before each number or use the MathU Pro keypad.

5-way Button Support

[Back to Top]

On devices with the 5-Way navigation button, the 5-way can be used to highlight and select the buttons on the keypad including the program pop-up. When no buttons are highlighted, the 5-way up and down scrolls the stack.

International Number Formats

[Back to Top]

MathU Pro honors the number format chosen in the Palm Prefs application. If you find that MathU Pro is displaying numbers using the wrong decimal or thousands separator, go to the system Prefs application and choose Formats from the Popup menu. Choose the number format for your locale from the Numbers: popup.

For number formats that use the comma as the decimal separator, MathU Pro displays instead of for the decimal button. Changing the number format affects the way values are displayed, copied, and interpreted during a paste.

Viewing the Stack and Registers

[Back to Top]

MathU Pro has 20 global registers -- 10 primary registers and 10 secondary registers. The secondary registers are used to store values for the financial and statistical functions or for your own programs. MathU Pro programs can also access another 26 local registers directly and up to 1024 local registers indirectly (see the Programming and Function Reference for details).

The 10 primary registers are accessed by pressing or and then the register number through . To access the secondary registers (registers 10 through 19) press and then the register number through . Another way to access the secondary registers is to swap the primary and secondary registers with and then use or (without the ).

The stack, registers, and variables can be viewed by choosing Display->Registers from the menu or by tapping the key twice. The stack can be viewed by tapping the display area.

Choose OK to return to MathU Pro. Tap on Register, Stack, or Variables to see the values. Tap Hex, Dec, Oct, or Bin to view integer values stored in the registers in the chosen number base. Select an element from the list to push it onto the stack.

Copy and Paste

[Back to Top]

MathU Pro allows you to copy the values in the display for export to other applications like the Memo Pad. Simply choose Edit->Copy from the Edit menu

to copy the currently displayed value onto the clipboard. The value put on the clipboard honors the display mode, number base, and the number of digits. Choose Edit-->Paste to push the current value on the clipboard onto the stack. If the string on the clipboard cannot be converted to a valid number, the Palm will beep (when system sounds are enabled) and the value of the x register will be unaffected.

Changing the active program

[Back to Top]

The currently active program is displayed in the pop-up menu on the main keyboard

To change the active program and to change the labels on the assigned keys, tap the pop-up menu and select from the list.

The programs listed will depend on what you have installed on your Palm device.

SD Card Support: Programs can be stored in RAM memory, internal memory or on expansion cards (e.g., SD cards or memory sticks). Witin SD cards, the programs within the PALM/Launcher directory (or its sub-directories) will be available. You can edit or run programs on the cards. In addition you can store MathU Pro on the SD card as well in order to save space in your internal RAM.

The program called "MathU Pro" is the default MathU Pro program and will always be available. To view and manage the currently installed programs, go to the Program List screen via the Program->Program List menu item.

From this screen you can create new programs, edit programs, duplicate, or delete programs. See the topic below called "Programming MathU Pro" for details on how to edit programs.

Installing and sharing programs

[Back to Top]

The programs for MathU Pro are distributed as Palm databases (files with a .PDB extension) and have names starting with mthU. For example, the "My Program" program shown in the screen above is stored in a database called "mthUMy Program.PDB". When you HotSync®, this database will automatically be copied to your Palm backup folder by the Backup Conduit. To share a program with friends, HotSync your Palm device, locate the database in the backup folder, and then give it to your friends. You can enclose Palm databases in e-mail, post them on a web site, or share them on floppies. You can also beam them (see below).

To install a program database, use the install tool available from the Palm Desktop. Palm databases are installed in exactly the same way as .PRC files.

If the newly installed program doesn't show up in the program list screen, select the Options->Refresh List item from the list view menu.

To create your own programs, see the topic below called "Programming MathU Pro".

Beaming a program

[Back to Top]

You can beam a program to a friend if your handheld and theirs support beaming and you are both using Palm OS 3.0 or higher. Check the documentation that came with your Palm OS device if you are not sure if your device supports beaming. You can beam a program from the list screen or the edit screen. When in the list screen, select the program you wish to beam and then select Options->Beam Program from the menu. When in the editor, just select Options->Beam Program from the menu.

Running a program

[Back to Top]

Programs are run when an assigned key is pressed (see "Changing the key labels" below for how to assign a program to a key). While the program is running the word "run" appears in the display. Press one of the hardware scroll buttons or any key on the keyboard to stop a running program.

Programming MathU Pro

[Back to Top]

To create your own programs, use the editor. This is accessed either by the Program menu or the Program List screen.

Choose Program->New Program or press the New button to create a new program. Select Program->Edit Program or press the Edit button to edit the currently selected program. New programs are automatically populated with a few program steps to get you started.

The Program Editor

[Back to Top]

The program editor screen has three parts

  1. The current program listing is shown in the table on the left. The steps for the current program are shown here. The list is scrollable and you can use drag and drop to rearrange the steps in the program.
  2. The list of available functions is shown in the table on the right. The pop-up menu above the table allows you to display the possible functions by category. Graffiti can be used to quickly select functions in this list. Drag a function from here to the listing to add it to your program.
  3. The parameter area. This area is used by some of the functions to set parameter values. Appropriate user interface controls will become visible in this area when certain functions are selected in the listing table. A function with a finite set of parameter values will allow you select an appropriate value from a pop-up list, while functions with numeric or string parameters allow you to enter the parameter in a text field. The screen under Changing Key Labels shows and example of both types of parameter editors.

Adding steps to a program

[Back to Top]

To add a step to your program, select the desired function in the right table and drag it into position in the listing. Alternatively, press the Ins button to insert the selected function below the currently selected step in the listing. If no listing step is selected, the step is inserted before the first step.

Graffiti can be used to select steps from the right table. We have found that this is the quickest way to find a desired step in the list. 

Deleting steps from a program

[Back to Top]

To delete a step from your program, select the step you would like to delete from your program and then press the Del button. This cannot be undone, so be careful when using the Del button.

Duplicating steps in a program

[Back to Top]

To duplicate a step in your program, select the step you would like to duplicate in your program and then press the Dup button.

Rearranging steps in a program

[Back to Top]

To change the position of a step in your program, simply drag the step to its new position. When you get to the top or bottom of the table, the program will automatically scroll so you can get to any steps that may be hidden.

Changing the title of a program

[Back to Top]

Tap the Detail button to change the name of your program.

The program title is the name shown in the program list and the pop-up menu on the calculator keyboard. Select "Emulate 4 element stack " when your program depends on four element stack for proper operation.

Changing the key labels

[Back to Top]

The labels on the calculator keys can be changed for each program. This allows you to customize the MathU keyboard to only include functions that are useful to you. To assign a label to a key on the keyboard, press the interface control shown when the desired label step is selected

This displays the button assignment screen. Labels that have been assigned are bold in the editor.

When this program is active, the name given to each label is displayed on the assigned key in uppercase. Pressing the selected key runs the program starting with the assigned label.

Tap and highlight the f and g keys to assign a button to the f or g shifted location. Unhighlight both the f and g keys to assign a button to the unshifted key.

The exact button layout will reflect your currently selected skin:

You can assign a label to any key including keys that are not part of the square screen.

Switching the screen orientation or opening/closing the input area may hide the additional buttons. When this happens, MathU Pro will automatically map your assigned labels to another key (usually the first open key).

The Program Debugger

[Back to Top]

The program debugger screen has two parts

On the left is the program listing and breakpoint display. On the right is the registers, stack, and variables display. On the top is displayed the value of the x register or the selected item in the register display. As on the main keypad, tapping the angle indicator brings up the preference dialog. Tap the edit button if you wish to quickly go to the editor to change the program.

Setting breakpoints

To set a breakpoint, tap the small line in the gutter next to the step you wish to stop at. Tap again to unset the breakpoint. When the breakpoint is active, a small square is drawn next to the stop (as shown on line 009 in the picture above). The next line to be executed is selected in the debugger. To move the current line, just tap in the listing area (but not in the gutter).

Stepping in the debugger

Tap the "Step" button to execute the currently selected line. The current line will move to the next step in the program. The stack, registers, and variables will update to reflect the results of the step. To quickly execute several lines tap the "Go" button. Execution will proceed until a breakpoint is encountered or until the program is finished. You can stop the execution at anytime by tapping anywhere on the screen.

Debugging from the main screen

Tap the "On" button to leave the debugger screen and return to the main screen. When the debugger is on, it will open automatically when it hits a breakpoint is encountered. In addition, the statistics button will switch to the R/S button

so that you begin execution right from the keypad. In this case tapping R/S is the same as tapping the "Go" button in the debugger. When you are finished debugging your program, just go back to the debugger and tap the "Off" button.

The MathU Pro Language

[Back to Top]

The MathU Pro language is keystroke based. A program is a sequence of keystrokes (steps) that are invoked in response to pressing the assigned button. The possible steps include numerical functions, stack and register functions, as well as steps like IF or LOOP that can be used to affect the flow of a program or to execute a series of steps a number of times. See the Programming and Function Reference for a detailed description of the available functions.

A program can contain one or more labels which are locations in the program that you can jump to when a key on the keyboard is pressed or via GOTO or GOSUB. By preceding a label with a return statement you can effectively create self contained functions (see example below).

The MathU Pro Functions

[Back to Top]

The functions on the default keyboard and the functions available via programming are both covered in detail in the Programming and Function Reference.

An Example Program

[Back to Top]

Here is an example program that makes the hyperbolic functions available from the keyboard. This simple program shows how easy it is to configure MathU Pro to provide access to a function that isn't on the default keyboard.


001 label cosh (f7)
002 cosh
003 return
004 label acosh (g7)
005 acosh
006 return

007 label sinh (f8)
008 sinh
009 return
010 label asinh (g8)
011 asinh
012 return

013 label tanh (f9)
014 tanh
015 return
016 label atanh (g9)
017 atanh
018 return

Legal Stuff

[Back to Top]

Although care has been taken to insure a bug-free program, Creative Creek, LLC makes no warranty whatsoever, either implied or expressed, as to the correct functioning of this software. When using this software, the user assumes all responsibility for any damages caused, directly or indirectly, by its use.

MathU Pro is copyrighted. Copyright laws apply and the software shall be classified as proprietary material. The unregistered version may be given to your friends. If you want to include MathU Pro on your web site or to distribute it in any way, please contact us at .

When you purchase MathU Pro you are granted a non-exclusive, nontransferable license to use the software and documentation for use in accordance with this License. This License allows use of the software by a single user unless otherwise specified by the description provided at time of purchase.

MathU Pro and Creative Creek are trademarks of Creative Creek, LLC. All other trademarks are of their respective owners.

Contacting Creative Creek

[Back to Top]

See the Creative Creek, LLC web site for up-to-date information about MathU Pro. If you have questions, suggestions, bug reports, or you just want to tell us how you much you like MathU Pro you can contact us at or on the web at www.creativecreek.com.

 

Copyright © 1998-2010 by Creative Creek, LLC and Clay M. Thompson -- All rights reserved.

Last updated: 10-May-2010